<?php
include_once $_SERVER['DOCUMENT_ROOT'] . '/include/shared-manual.inc';
$TOC = array();
$TOC_DEPRECATED = array();
$PARENTS = array();
include_once dirname(__FILE__) ."/toc/filter.constants.inc";
$setup = array (
  'home' => 
  array (
    0 => 'index.php',
    1 => 'PHP Manual',
  ),
  'head' => 
  array (
    0 => 'UTF-8',
    1 => 'fr',
  ),
  'this' => 
  array (
    0 => 'filter.constants.validation.php',
    1 => 'Filtres de Validation',
    2 => 'Filtres de Validation',
  ),
  'up' => 
  array (
    0 => 'filter.constants.php',
    1 => 'Constantes pr&eacute;-d&eacute;finies',
  ),
  'prev' => 
  array (
    0 => 'filter.constants.flags.sanitization.php',
    1 => 'Drapeaux de Filtrage de Sanitation',
  ),
  'next' => 
  array (
    0 => 'filter.constants.sanitization.php',
    1 => 'Filtres de Sanitisation',
  ),
  'alternatives' => 
  array (
  ),
  'source' => 
  array (
    'lang' => 'fr',
    'path' => 'reference/filter/constants.validation.xml',
  ),
  'history' => 
  array (
  ),
);
$setup["toc"] = $TOC;
$setup["toc_deprecated"] = $TOC_DEPRECATED;
$setup["parents"] = $PARENTS;
manual_setup($setup);

contributors($setup);

?>
<div id="filter.constants.validation" class="section">
 <h2 class="title">Filtres de Validation</h2>
 <p class="simpara">Ces constantes sont définies par cette
extension, et ne sont disponibles que si cette extension a été compilée avec
PHP, ou bien chargée au moment de l&#039;exécution.</p>
 <dl>
  
   <dt id="constant.filter-validate-bool">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-bool">FILTER_VALIDATE_BOOL</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Retourne <strong><code><a href="reserved.constants.php#constant.true">true</a></code></strong> pour <code class="literal">&quot;1&quot;</code>,
     <code class="literal">1</code>, y compris les notations binaire, octale et hexadécimale, <code class="literal">1.0</code>, y compris la notation scientifique,
     <code class="literal">&quot;true&quot;</code>, <strong><code><a href="reserved.constants.php#constant.true">true</a></code></strong>,
     <code class="literal">&quot;on&quot;</code>,
     et <code class="literal">&quot;yes&quot;</code>.
    </p>
    <p class="simpara">
     Retourne <strong><code><a href="reserved.constants.php#constant.false">false</a></code></strong> pour <code class="literal">&quot;0&quot;</code>,
     <code class="literal">0</code>, y compris les notations binaire, octale et hexadécimale, <code class="literal">0.0</code>, y compris la notation scientifique,
     <code class="literal">&quot;false&quot;</code>, <strong><code><a href="reserved.constants.php#constant.false">false</a></code></strong>,
     <code class="literal">&quot;off&quot;</code>,
     <code class="literal">&quot;no&quot;</code>, et
     <code class="literal">&quot;&quot;</code>.
    </p>
    <p class="simpara">
     Les valeurs de type chaîne sont comparées sans tenir compte de la casse.
     La valeur retournée pour des valeurs non booléennes dépend de
     <strong><code><a href="filter.constants.flags.generic.php#constant.filter-null-on-failure">FILTER_NULL_ON_FAILURE</a></code></strong>.
     Si ce dernier est défini, <strong><code><a href="reserved.constants.php#constant.null">null</a></code></strong> est retourné, sinon <strong><code><a href="reserved.constants.php#constant.false">false</a></code></strong> est retourné.
    </p>
    <dl id="filter.constants.validation.bool.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
    </dl>
    <p class="simpara">
     Disponible à partir de PHP 8.0.0.
    </p>
   </dd>
  

  
   <dt id="constant.filter-validate-boolean">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-boolean">FILTER_VALIDATE_BOOLEAN</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Alias de <strong><code><a href="filter.constants.validation.php#constant.filter-validate-bool">FILTER_VALIDATE_BOOL</a></code></strong>.
     Cet alias était disponible avant l&#039;introduction de son nom canonique
     dans PHP 8.0.0.
    </p>
   </dd>
  

  
   <dt id="constant.filter-validate-int">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-int">FILTER_VALIDATE_INT</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si la valeur est un entier,
     en cas de succès, elle est convertie en type <span class="type"><a href="language.types.integer.php" class="type int">int</a></span>.
    </p>

    <blockquote class="note"><p><strong class="note">Note</strong>: 
     <p class="simpara">
      Les chaînes de caractères sont nettoyées à l&#039;aide de <span class="function"><a href="function.trim.php" class="function">trim()</a></span>
      avant validation.
     </p>
    </p></blockquote>

    <dl id="filter.constants.validation.int.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
     
      <dt><code class="literal">min_range</code></dt>
      <dd>
       <p class="simpara">
        La valeur est valide seulement si elle est supérieure ou égale à la valeur fournie.
       </p>
      </dd>
     
     
      <dt><code class="literal">max_range</code></dt>
      <dd>
       <p class="simpara">
        La valeur est valide seulement si elle est inférieure ou égale à la valeur fournie.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.int.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt id="constant.filter-flag-allow-octal">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-allow-octal">FILTER_FLAG_ALLOW_OCTAL</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        
        Permet les entiers en notation octale
        (<code class="literal">0[0-7]+</code>).
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-allow-hex">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-allow-hex">FILTER_FLAG_ALLOW_HEX</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Permet les entiers en notation hexadécimale
        (<code class="literal">0x[0-9a-fA-F]+</code>).
       </p>
      </dd>
     
    </dl>
   </dd>
  
  
   <dt id="constant.filter-validate-float">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-float">FILTER_VALIDATE_FLOAT</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si la valeur est un nombre flottant,
     en cas de succès, elle est convertie en type <span class="type"><a href="language.types.float.php" class="type float">float</a></span>.
    </p>

    <blockquote class="note"><p><strong class="note">Note</strong>: 
     <p class="simpara">
      Les chaînes de caractères sont nettoyées à l&#039;aide de <span class="function"><a href="function.trim.php" class="function">trim()</a></span>
      avant validation.
     </p>
    </p></blockquote>

    <dl id="filter.constants.validation.float.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
     
      <dt><code class="literal">decimal</code></dt>
      <dd>
       <p class="simpara">
        
       </p>
      </dd>
     
     
      <dt><code class="literal">min_range</code></dt>
      <dd>
       <p class="simpara">
        La valeur est valide seulement si elle est supérieure ou égale à la valeur fournie.
        Disponible à partir de PHP 7.4.0.
       </p>
      </dd>
     
     
      <dt><code class="literal">max_range</code></dt>
      <dd>
       <p class="simpara">
        La valeur est valide seulement si elle est inférieure ou égale à la valeur fournie.
        Disponible à partir de PHP 7.4.0.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.float.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt>
       <strong><code><a href="filter.constants.sanitization.php#constant.filter-flag-allow-thousand">FILTER_FLAG_ALLOW_THOUSAND</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Accepte les virgules (<code class="literal">,</code>),
        qui représentent généralement le séparateur de milliers.
       </p>
      </dd>
     
    </dl>
   </dd>
  

  
   <dt id="constant.filter-validate-regexp">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-regexp">FILTER_VALIDATE_REGEXP</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide la valeur en fonction de l&#039;expression régulière fournie par l&#039;option
     <code class="literal">regexp</code>.
    </p>

    <dl id="filter.constants.validation.regex.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
     
      <dt><code class="literal">regexp</code></dt>
      <dd>
       <p class="simpara">
        Expression régulière compatible <a href="book.pcre.php" class="link">Perl</a>.
       </p>
      </dd>
     
    </dl>
   </dd>
  
  
   <dt id="constant.filter-validate-url">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-url">FILTER_VALIDATE_URL</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si l&#039;<abbr title="Uniform Resource Locator">URL</abbr> est valide selon
     <a href="https://datatracker.ietf.org/doc/html/rfc2396" class="link external">&raquo;&nbsp;RFC 2396</a>.
    </p>
    <dl id="filter.constants.validation.url.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.url.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt id="constant.filter-flag-scheme-required">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-scheme-required">FILTER_FLAG_SCHEME_REQUIRED</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Exige que l&#039;<abbr title="Uniform Resource Locator">URL</abbr> contienne une partie schéma.
       </p>
       <div class="warning"><strong class="warning">Avertissement</strong>
        <p class="simpara">
         <em>OBSOLÈTE</em> à partir de PHP 7.3.0 et
         <em>SUPPRIMÉ</em> à partir de PHP 8.0.0.
         Cela est dû au fait qu&#039;il est toujours implicite avec
         le filtre <strong><code><a href="filter.constants.validation.php#constant.filter-validate-url">FILTER_VALIDATE_URL</a></code></strong>.
        </p>
       </div>
      </dd>
     
     
      <dt id="constant.filter-flag-host-required">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-host-required">FILTER_FLAG_HOST_REQUIRED</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Exige que l&#039;<abbr title="Uniform Resource Locator">URL</abbr> contienne une partie hôte.
       </p>
       <div class="warning"><strong class="warning">Avertissement</strong>
        <p class="simpara">
         <em>OBSOLÈTE</em> à partir de PHP 7.3.0 et
         <em>SUPPRIMÉ</em> à partir de PHP 8.0.0.
         Cela est dû au fait qu&#039;il est toujours implicite avec
         le filtre <strong><code><a href="filter.constants.validation.php#constant.filter-validate-url">FILTER_VALIDATE_URL</a></code></strong> pour la plupart des schémas.
        </p>
       </div>
      </dd>
     
     
      <dt id="constant.filter-flag-path-required">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-path-required">FILTER_FLAG_PATH_REQUIRED</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Exige que l&#039;<abbr title="Uniform Resource Locator">URL</abbr> contienne une partie chemin.
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-query-required">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-query-required">FILTER_FLAG_QUERY_REQUIRED</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Exige que l&#039;<abbr title="Uniform Resource Locator">URL</abbr> contienne une partie requête.
       </p>
      </dd>
     
    </dl>
    <div class="warning"><strong class="warning">Avertissement</strong>
     <p class="simpara">
      Une <abbr title="Uniform Resource Locator">URL</abbr> valide peut ne pas spécifier le
      protocole <abbr title="Hypertext Transfer Protocol">HTTP</abbr> (<code class="literal">http://</code>).
      Une validation supplémentaire peut donc être nécessaire pour vérifier si l&#039;<abbr title="Uniform Resource Locator">URL</abbr>
      utilise un protocole attendu, par exemple <code class="literal">ssh://</code> ou <code class="literal">mailto:</code>.
     </p>
    </div>
    <div class="warning"><strong class="warning">Avertissement</strong>
     <p class="simpara">
      Ce filtre ne fonctionne que sur les <abbr title="Uniform Resource Locator">URL</abbr>s <abbr title="American Standard Code for Information Interchange">ASCII</abbr>.
      Cela signifie que les noms de domaine internationalisés (IDN) seront toujours rejetés.
     </p>
    </div>
    <div class="warning"><strong class="warning">Avertissement</strong>
     <p class="simpara">
      Ce filtre est très permissif. Pour tout schéma autre que
      <code class="literal">http://</code> ou <code class="literal">https://</code>, le contenu
      de l&#039;hôte sera accepté sans aucune validation, bien que la présence
      d&#039;un hôte reste requise sauf si l&#039;<abbr title="Uniform Resource Locator">URL</abbr> a pour schéma
      <code class="literal">mailto:</code>, <code class="literal">news:</code> ou
      <code class="literal">file:</code>. Les schémas eux-mêmes ne sont pas validés et
      peuvent être acceptés même s&#039;ils ne correspondent pas à un schéma
      d&#039;<abbr title="Uniform Resource Locator">URL</abbr> connu, ou s&#039;ils ont une autre signification en
      PHP (comme <a href="book.phar.php" class="link">phar://</a>). Le filtre
      accepte également les adresses
      <a href="https://en.wikipedia.org/wiki/Loopback" class="link external">&raquo;&nbsp;loopback</a>
      correspondant à l&#039;hôte courant.
     </p>
     <div class="informalexample">
      <div class="example-contents">
<div class="phpcode"><pre><code style="color: #000000"><span style="color: #0000BB">&lt;?php

var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'javascript://x%0aalert(1)'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'javascript://?demo'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'news:?demo'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'phar://demo'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'123://demo'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'-://demo'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'http://127.0.0.1'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">'gopher://127.0.0.1'</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_URL</span><span style="color: #007700">));
</span><span style="color: #0000BB">?&gt;</span></code></pre></div>
      </div>

      <p class="simpara">L&#039;exemple ci-dessus va afficher :</p>
      <div class="example-contents screen">
<div class="cdata"><pre>
string(25) &quot;javascript://x%0aalert(1)&quot;
bool(false)
string(10) &quot;news:?demo&quot;
string(11) &quot;phar://demo&quot;
string(10) &quot;123://demo&quot;
string(8) &quot;-://demo&quot;
string(16) &quot;http://127.0.0.1&quot;
string(18) &quot;gopher://127.0.0.1&quot;
</pre></div>
      </div>
     </div>
    </div>
   </dd>
  

  
   <dt id="constant.filter-validate-domain">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-domain">FILTER_VALIDATE_DOMAIN</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si le nom de domaine est valide selon
     <a href="https://datatracker.ietf.org/doc/html/rfc952" class="link external">&raquo;&nbsp;RFC 952</a>,
     <a href="https://datatracker.ietf.org/doc/html/rfc1034" class="link external">&raquo;&nbsp;RFC 1034</a>,
     <a href="https://datatracker.ietf.org/doc/html/rfc1035" class="link external">&raquo;&nbsp;RFC 1035</a>,
     <a href="https://datatracker.ietf.org/doc/html/rfc1034" class="link external">&raquo;&nbsp;RFC 1123</a>,
     <a href="https://datatracker.ietf.org/doc/html/rfc1034" class="link external">&raquo;&nbsp;RFC 2732</a>,
     et
     <a href="https://datatracker.ietf.org/doc/html/rfc2181" class="link external">&raquo;&nbsp;RFC 2181</a>.
    </p>
    <dl id="filter.constants.validation.domain.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner si le filtre échoue.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.domain.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt id="constant.filter-flag-hostname">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-hostname">FILTER_FLAG_HOSTNAME</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Exige que les noms d&#039;hôte commencent par un caractère alphanumérique
        et ne contiennent que des caractères alphanumériques ou des traits d&#039;union.
       </p>
      </dd>
     
    </dl>
    <div class="warning"><strong class="warning">Avertissement</strong>
     <p class="simpara">
      Ce filtre est très permissif. Comme spécifié dans la
      <a href="https://datatracker.ietf.org/doc/html/rfc2181" class="link external">&raquo;&nbsp;RFC 2181</a>, un nom de domaine
      valide est une chaîne d&#039;au plus 253 caractères (254 avec un séparateur
      <code class="literal">.</code> final) dont chaque étiquette (séparée par un
      <code class="literal">.</code>) compte au plus 63 caractères. Sauf si
      <strong><code><a href="filter.constants.validation.php#constant.filter-flag-hostname">FILTER_FLAG_HOSTNAME</a></code></strong> est utilisé pour s&#039;assurer que
      le domaine est aussi un nom d&#039;hôte valide, les espaces blancs, les
      métacaractères, les octets de contrôle et même les octets NUL sont
      acceptés par le filtre.
     </p>
     <div class="informalexample">
      <div class="example-contents">
<div class="phpcode"><pre><code style="color: #000000"><span style="color: #0000BB">&lt;?php

var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">"!@#$%^&amp;*(){}[]/?=+\|`~\"'&lt;&gt;,"</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_DOMAIN</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">"null byte: &gt;\0&lt;"</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_DOMAIN</span><span style="color: #007700">));
</span><span style="color: #0000BB">var_dump</span><span style="color: #007700">(</span><span style="color: #0000BB">filter_var</span><span style="color: #007700">(</span><span style="color: #DD0000">"space:&gt; &lt;, tab:&gt;\t&lt;, newline: &gt;\n&lt;, carriage return&gt;\r&lt;"</span><span style="color: #007700">, </span><span style="color: #0000BB">FILTER_VALIDATE_DOMAIN</span><span style="color: #007700">));
</span><span style="color: #0000BB">?&gt;</span></code></pre></div>
      </div>

      <p class="simpara">L&#039;exemple ci-dessus va afficher :</p>
      <div class="example-contents screen">
<div class="cdata"><pre>
string(27) &quot;!@#$%^&amp;*(){}[]/?=+\|`~&quot;&#039;&lt;&gt;,&quot;
string(14) &quot;null byte: &gt;&lt;&quot;
string(52) &quot;space:&gt; &lt;, tab:&gt;	&lt;, newline: &gt;
&lt;, carriage return&gt;
&lt;&quot;
</pre></div>
      </div>
     </div>
    </div>
   </dd>
  
  
   <dt id="constant.filter-validate-email">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-email">FILTER_VALIDATE_EMAIL</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si la valeur est une adresse e-mail &quot;valide&quot;.
    </p>

    <p class="simpara">
     La validation est effectuée selon la syntaxe <code class="literal">addr-spec</code>
     dans le
     <a href="https://datatracker.ietf.org/doc/html/rfc822" class="link external">&raquo;&nbsp;RFC 822</a>.
     Cependant, les commentaires, le pliage des espaces blancs et les noms de domaine sans point
     ne sont pas pris en charge et seront donc rejetés.
    </p>

    <dl id="filter.constants.validation.email.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner en cas d&#039;échec du filtre.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.email.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt id="constant.filter-flag-email-unicode">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-email-unicode">FILTER_FLAG_EMAIL_UNICODE</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Accepte les caractères Unicode dans la partie locale.
        Disponible à partir de PHP 7.1.0.
       </p>
      </dd>
     
    </dl>

    <div class="warning"><strong class="warning">Avertissement</strong>
     <p class="simpara">
      La validation des e-mails est complexe et le seul moyen fiable de confirmer qu&#039;un e-mail
      est valide et existe est d&#039;envoyer un e-mail à l&#039;adresse.
     </p>
    </div>
   </dd>
  
  
   <dt id="constant.filter-validate-ip">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-ip">FILTER_VALIDATE_IP</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide la valeur en tant qu&#039;adresse IP.
    </p>
    <dl id="filter.constants.validation.ip.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner en cas d&#039;échec du filtre.
       </p>
      </dd>
     
    </dl>
    <dl id="filter.constants.validation.ip.flags">
     <strong class="title">Options facultatives</strong>
     
      <dt id="constant.filter-flag-ipv4">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-ipv4">FILTER_FLAG_IPV4</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Autoriser les adresses IPv4.
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-ipv6">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-ipv6">FILTER_FLAG_IPV6</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Autoriser les adresses IPv6.
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-no-res-range">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-no-res-range">FILTER_FLAG_NO_RES_RANGE</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Refuser les adresses réservées.
       </p>
       <p class="simpara">
        Ce sont les plages qui sont marquées comme
        <code class="literal">Reserved-By-Protocol</code> dans
        <a href="https://datatracker.ietf.org/doc/html/rfc6890" class="link external">&raquo;&nbsp;RFC 6890</a>.
       </p>
       <p class="para">
        Pour IPv4, cela correspond aux plages suivantes :
        <span class="simplelist"><code class="literal">0.0.0.0/8</code>, <code class="literal">169.254.0.0/16</code>, <code class="literal">127.0.0.0/8</code>, <code class="literal">240.0.0.0/4</code></span>.
       </p>
       <p class="para">
        Et pour IPv6, cela correspond aux plages suivantes :
        <span class="simplelist"><code class="literal">::1/128</code>, <code class="literal">::/128</code>, <code class="literal">::FFFF:0:0/96</code>, <code class="literal">FE80::/10</code></span>.
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-no-priv-range">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-no-priv-range">FILTER_FLAG_NO_PRIV_RANGE</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        Refuser les adresses privées.
       </p>
       <p class="para">
        Ce sont des adresses IPv4 qui se trouvent dans les plages suivantes :
        <span class="simplelist"><code class="literal">10.0.0.0/8</code>, <code class="literal">172.16.0.0/12</code>, <code class="literal">192.168.0.0/16</code></span>.
       </p>
       <p class="simpara">
        Ce sont des adresses IPv6 commençant par
        <code class="literal">FD</code> ou <code class="literal">FC</code>.
       </p>
      </dd>
     
     
      <dt id="constant.filter-flag-global-range">
       <strong><code><a href="filter.constants.validation.php#constant.filter-flag-global-range">FILTER_FLAG_GLOBAL_RANGE</a></code></strong>
       (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
      </dt>
      <dd>
       <p class="simpara">
        N&#039;autoriser que les adresses globales.
        Celles-ci peuvent être trouvées dans
        <a href="https://datatracker.ietf.org/doc/html/rfc6890" class="link external">&raquo;&nbsp;RFC 6890</a>
        où l&#039;attribut <code class="literal">Global</code> est <code class="literal">True</code>.
        Disponible à partir de PHP 8.2.0.
       </p>
      </dd>
     
    </dl>
   </dd>
  

  
   <dt id="constant.filter-validate-mac">
    <strong><code><a href="filter.constants.validation.php#constant.filter-validate-mac">FILTER_VALIDATE_MAC</a></code></strong>
    (<span class="type"><a href="language.types.integer.php" class="type int">int</a></span>)
   </dt>
   <dd>
    <p class="simpara">
     Valide si la valeur est une adresse MAC.
    </p>

    <dl id="filter.constants.validation.mac.options">
     <strong class="title">Options disponibles</strong>
     
      <dt><code class="literal">default</code></dt>
      <dd>
       <p class="simpara">
        Valeur à retourner en cas d&#039;échec du filtre.
       </p>
      </dd>
     
    </dl>
   </dd>
  
 </dl>
</div><?php manual_footer($setup); ?>